May 1st Data
Incident Report for Fuze
Resolved
We have finished restoring the data and expect all data to be fully recovered.

Again, we apologize for any inconvenience caused and thank you for your patience while we worked to resolve this issue.
Posted May 06, 2020 - 17:12 EDT
Identified
We have identified the cause and are actively restoring the data. We expect all data to be fully recovered. We will send out a final update once the recovery is completed.
Posted May 06, 2020 - 12:58 EDT
Investigating
Fuze has identified an issue where a subset of customers are unable to view queue summary data for May 1st in Fuze View. We are working diligently to identify the issue and reload the data. We will provide regular updates until the issue has been resolved. We apologize for any inconvenience caused and appreciate your patience.
Posted May 06, 2020 - 11:40 EDT
This incident affected: Admin Services - Global (Fuze Data, Reporting, and/or Discover Services).