Service Degradation
Incident Report for Fuze
Resolved
We have resolved the issue with OrcaFax and it should be working normally now. We do expect some amount of delay, but all lingering faxes should be delivered within 24 hours.

Again, we apologize for any inconvenience caused and thank you for your patience while we worked to resolve this issue.
Posted Oct 11, 2018 - 17:01 EDT
Investigating
We have identified an issue with a subset of customers being unable to utilize the Orcafax service. Rest assured, we are working diligently to identify the issue and will provide regular updates until the issue has been resolved. We apologize for any inconvenience caused and appreciate your patience.
Posted Oct 11, 2018 - 11:08 EDT
This incident affected: Fax to Email - Global (e-Fax Services).