Third Party Carrier Network Issues
Incident Report for Fuze
Resolved
Third party carrier issues have been resolved. All Fuze services remain operational.
Posted Jun 16, 2020 - 07:50 EDT
Identified
Several national carriers in the US, including AT&T, T-Mobile, and Verizon are currently experiencing network issues. These can affect performance of Fuze services for any customers using those carriers. If you are experiencing issues with your Fuze services, please check with your carrier first. If that does not seem to be the cause, please open a new case with Fuze Support and our team will work to identify your issue per usual.

We apologize for any inconvenience this may have caused and we appreciate your patience.
Posted Jun 15, 2020 - 16:40 EDT
This incident affected: Contact Center Services - North America (Ashburn, VA, Boston, MA, San Francisco, CA, San Jose, CA), Voice Services - North America (Ashburn, VA, Boston, MA, San Francisco, CA, San Jose, CA), Messaging Services - North America (Ashburn, VA, Boston, MA, San Francisco, CA, San Jose, CA), and Fuze Meetings - Global (Ashburn, VA, San Jose, CA).