Fuze for Google Calendar
Incident Report for Fuze
Resolved
The issue with Fuze for Google Calendar has been resolved in the newest version of those browser extensions. Updated Extensions can be found and installed from our Marketplace here:
https://marketplace.fuze.com/category/browsers

Thank you for your patience while we resolved this issue. If you continue to have issues, please contact Fuze Support for further assistance.
Posted Sep 17, 2020 - 08:25 EDT
Identified
We have identified the issue and our development team is in the process of testing a fix. We will keep you updated as the fix progresses.
Posted Sep 14, 2020 - 15:45 EDT
Investigating
We are aware of issues scheduling Fuze meetings directly from Google Calendar. This issue does not impact the ability to join/host Fuze meetings, or to schedule meetings from the Fuze app.

We are actively working to restore functionality from within Google Calendar and will provide updates as we have them.
Posted Sep 14, 2020 - 13:25 EDT
This incident affected: Integrations - Global (Fuze for Chrome, Fuze for Firefox).