inContact Degraded Services
Incident Report for Fuze
Resolved
This issue has now been resolved by inContact. If you are experiencing any further problems, please contact support.
Posted Aug 01, 2018 - 21:15 EDT
Monitoring
inContact is experiencing service degradation that may impact enhanced call routing functionality for some customers that make use of this service.
Posted Aug 01, 2018 - 11:56 EDT