Call Drops
Incident Report for Fuze
Resolved
We have resolved the issue, and expect that all services are functioning normally.

Again, we apologize for any inconvenience caused and thank you for your patience while we worked to resolve this issue.
Posted Mar 21, 2020 - 18:30 EDT
Monitoring
We have resolved the issue, and expect that all services are functioning normally.

Again, we apologize for any inconvenience caused and thank you for your patience while we worked to resolve this issue.
Posted Mar 21, 2020 - 17:44 EDT
Investigating
We are currently investigating a call server in Boston. Some users may experience dropped calls. Rest assured, we are working diligently to identify the issue and will provide regular updates until the issue has been resolved. We apologize for any inconvenience this may cause and thank you for your patience.
Posted Mar 21, 2020 - 16:42 EDT
This incident affected: Voice Services - North America (Boston, MA).