Partial Outage
Incident Report for Fuze
Resolved
The third-party provider has indicated that all services for customers who experienced disruption have been restored. If you continue to experience issues, please contact support via the Fuze Community.
Posted Apr 22, 2020 - 09:53 EDT
Update
We continue to monitor resolution progress by the third-party provider. All Fuze services are operational. If you continue to experience issues, please contact support via the Community. To ensure the quickest feedback, please make reference to Incident 3927
Posted Apr 21, 2020 - 18:37 EDT
Update
We are continuing to monitor for any further issues.
Posted Apr 21, 2020 - 18:36 EDT
Update
The third-party provider has made progress in resolving the issue, and we have confirmed that voice services are being restored. All Fuze services are operational. We will monitor this event for the next 30 minutes before setting the status to "resolved." If you continue to experience issues, please contact support via the Community. To ensure the quickest feedback, please make reference to Incident 3927.
Posted Apr 21, 2020 - 17:42 EDT
Update
The ongoing third-party service provider issue is also impacting voice services. To help mitigate the issue we have made routing adjustments in the impacted areas and have bypassed the third-party service provider. Some individual customers may be impacted dependent on routes their ISP is using. The carrier has posted details here: https://twitter.com/centurylinkhelp/status/1252654592069951488?s=21
Posted Apr 21, 2020 - 15:12 EDT
Update
Upon investigation, we have determined the issue is related to a fiber cut on a third-party service provider network. To help mitigate the issue we have made routing adjustments in the impacted areas and have bypassed the third-party service provider. Some individual customers may be impacted dependent on routes their ISP is using.
Posted Apr 21, 2020 - 14:26 EDT
Monitoring
There are no further reports of dropped meetings or an inability to connect to meetings. We will monitor this event for the next 30 minutes before setting the status to "resolved." If you continue to experience issues, please contact support via the Community. To ensure the quickest feedback, please make reference to incident 3927.

We apologize for any inconvenience caused and thank you for your patience while we worked to resolve this issue.
Posted Apr 21, 2020 - 13:02 EDT
Update
Fuze is continuing to investigate this issue but at this time we are seeing no new reports of dropped meetings or an inability to connect to meetings. Rest assured, we are working diligently to identify the issue and will provide regular updates until the issue has been resolved. We apologize for any inconvenience this may cause and thank you for your patience.
Posted Apr 21, 2020 - 11:57 EDT
Investigating
We are investigating an issue which may cause some users to be disconnected or have intermittent trouble connecting to meetings. Rest assured, we are working diligently to identify the issue and will provide regular updates until the issue has been resolved. We apologize for any inconvenience this may cause and thank you for your patience.
Posted Apr 21, 2020 - 10:43 EDT
This incident affected: Fuze Meetings - Global (Ashburn, VA, Frankfurt, DE, San Jose, CA, Singapore, SG, Sydney, AU) and Voice Services - North America (Ashburn, VA, Boston, MA, San Francisco, CA, San Jose, CA).