Degraded Performance - Third Party Impacts
Incident Report for Fuze
Resolved
We have worked with FirstLight to resolve the issue, and expect that all services are functioning normally.

Again, we apologize for any inconvenience caused and thank you for your patience while we worked to resolve this issue.
Posted Sep 13, 2018 - 11:08 EDT
Identified
We have been alerted to an issue a partner carrier is having with Toll Free Numbers. We are actively working with them to resolve. More detailed information can be found at https://www.firstlight.net

We apologize for any inconvenience this may have caused and we appreciate your patience.
Posted Sep 13, 2018 - 09:13 EDT