Outage on our Hub platform
Incident Report for Fuze
Resolved
We can confirm that the service is now operational as usual. Please let our support team know if you encounter any further issues.
May thanks
Posted Nov 28, 2022 - 05:44 EST
Investigating
We are experiencing an outage on our Hub platform.

End-user services may be impacted.

We are working diligently to identify the cause of the issue and will provide regular updates as we have them. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Nov 28, 2022 - 05:34 EST
This incident affected: FuzeCC Services - Europe (Frankfurt, DE, London, UK).