Unable to receive/send faxes
Incident Report for Fuze
Resolved
This incident has been resolved.
Posted Nov 06, 2018 - 12:52 EST
Update
We have resolved the issue, and expect that all services are functioning normally. We will monitor this event for the next 30 minutes before setting the status to "resolved." If you continue to experience issues, please contact support via the Community. To ensure the quickest feedback, please make reference to incident 2355.

We apologize for any inconvenience caused and thank you for your patience while we worked to resolve this issue.
Posted Nov 06, 2018 - 11:49 EST
Investigating
We are receiving reports of eFax service being unavailable. We are working on resuming services as soon as possible. We will continue to send updates as they are available. We apologize for any inconvenience caused and thank you for your patience.
Posted Nov 06, 2018 - 11:30 EST
This incident affected: Fax to Email - Global (e-Fax Services).