Fuze Hub Access Issue
Incident Report for Fuze
Resolved
This incident has now been resolved. If you are experiencing any further issues, please contact support.
Posted Mar 16, 2020 - 23:26 EDT
Monitoring
The issue has been identified and resolved. All access to Fuze HUB should now be restored. If you have any further issues, please contact support. We will continue to monitor this for the next hour before resolving this incident.
Posted Mar 16, 2020 - 21:52 EDT
Investigating
Access to the Fuze HUB is currently not available. We are working to resolve this issue as soon as possible. We apologise for the inconvenience. More information will be posted as it becomes available.
Posted Mar 16, 2020 - 21:09 EDT
This incident affected: Admin Services - Global (Fuze Hub).