Fuze Discover - unable to login
Incident Report for Fuze
Resolved
This incident has been resolved.
Posted Jul 16, 2020 - 04:34 EDT
Monitoring
Users are able to log in to Fuze Discover now.
We apologise for any inconvenience this caused.
Posted Jul 16, 2020 - 04:32 EDT
Investigating
We have reports that users are unable to log in to Fuze Discover at the moment.
Fuze Hub, Portal, Data and Reporting are unaffected.

We are investigating and are trying to get this working again as soon as possible.
We will post further updates as soon as we have some further news.
Posted Jul 16, 2020 - 04:27 EDT
This incident affected: Admin Services - Global (Fuze Data, Reporting, and/or Discover Services).